Warning/Possible Issue
Minor incident
Xbox One - Physera
Xbox One - Physera Channel 1
2020-10-22 08:01 PDT
·
9 minutes
Updates
Resolved
October 22, 2020 · 08:10 PDT
We found the root of the issue and we have fixed it.
Issue
October 22, 2020 · 08:03 PDT
There are currently issues that may prevent access to certain parts of the game.
← Back